Why can't I use my old browser on Traxsource?

Author Traxsource Support on January 16, 2013 | Print | Bookmark
The new Traxsource is built using the latest web standard called HTML5. 

Below is a list of "Approved" browsers that supports this technology  and provide the best experience on Traxsource.com

Google Chrome 

Opera   

FireFox

Safari    

Internet Explorer  Ver.10 and above

Click on your preferred browser above to get the latest HTML5 compatible version.

Was this article helpful?

Yes No

Category: Getting Started FAQ, ALL NEW Traxsource Functions

Last updated on November 6, 2015 with 4797 views